Xem Nhiều 12/2022 #️ Cấu Hình Switch Port, Vlans, Trunk, Vtp, Intervlan Routing / 2023 # Top 15 Trend | Uplusgold.com

Xem Nhiều 12/2022 # Cấu Hình Switch Port, Vlans, Trunk, Vtp, Intervlan Routing / 2023 # Top 15 Trend

Cập nhật thông tin chi tiết về Cấu Hình Switch Port, Vlans, Trunk, Vtp, Intervlan Routing / 2023 mới nhất trên website Uplusgold.com. Hy vọng nội dung bài viết sẽ đáp ứng được nhu cầu của bạn, chúng tôi sẽ thường xuyên cập nhật mới nội dung để bạn nhận được thông tin nhanh chóng và chính xác nhất.

Yêu cầu:

Cấu hình trung kế:

Cấu hình trung kế Dot1q kết nối giữa Switch – Switch.

Cấu hình trung kế Dot1q kết nối giữa Switch – Router.

Cấu hình VTP:

Mỗi nhóm cấu hình VTP theo các yêu cầu sau:

VTP domain: BCMSNx (x là số thứ tự của nhóm, x = 1,2,3).

VTP pass: CISCO (lưu ý chữ hoa chữ thường).

SWx1 là VTP server.

SWx2, SWx3 là VTP client.

Cấu hình VLANs:

Mỗi nhóm tạo 3 VLANs tương ứng với mô hình trên

Ví dụ: nhóm 1 tạo VLAN11, VLAN12, VLAN13.

Gán port vào VLAN như sau:

x là số thứ tự của nhóm (x = 1,2,3).

Cấu hình định tuyến giữa các VLAN:

Mỗi nhóm cấu hình để 3 VLAN trong mỗi nhóm có thể ping thấy nhau.

Mỗi nhóm cấu hình giao thức định tuyến OSPF để tất cả VLAN và Interface Loopback có thể ping thấy nhau.

  Gợi ý:

2a: Dùng lệnh sau trên switch trong mode interface:

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# switchport mode trunk

!Lưu ý: phải gõ lệnh “switchport trunk encapsulation dot1q” trước lệnh “switchport mode trunk”, nếu gõ theo thứ tự ngược lại sẽ không thể tạo kết nối trung kế thành công

2b: Dùng lệnh sau trên router để cấu hình trung kế dot1q:

Router(config)# interface fastethernet 0/0.11

Router(config-if)# encapsulation dot1q 10

Router(config-if)# ip address 192.168.1.1 255.255.255.0

!lưu ý: câu lệnh trên tạo subinterface f0/0.11, chỉ định encapsulation là dot1q, thuộc VLAN 10 và có IP 192.168.1.1.

3: Dùng lệnh sau để cấu hình VTP:

Switch(config)# vtp domain BCMSN

Switch(config)# vtp password CISCO

4: Dùng các lệnh sau để cấu hình VLAN:

Switch(config)# vlan 10

Switch(config-vlan)# name VLAN10                       !ßđặt tên là VLAN10

Switch(config)# interface range fastethernet 0/1 – 6

Switch(config-if-range)# switchport mode access

Switch(config-if-range)# switchport access vlan 10        

Cấu hình đầy đủ:

!Nhóm 1:

!SW11:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN1

vtp pass CISCO

! vlan 11

name VLAN11

! vlan 12

name VLAN12

! vlan 13

name VLAN13

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 11

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 12

! int range fastEthernet0/17 – 23

switchport mode access

switchport access vlan 13

! end

!SW12:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN1

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 11

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 12

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 13

! end

SW13:

configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN1

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 11

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 12

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 13

! end

!R11:

configure terminal

! interface loopback0

ip address 1.1.1.1 255.255.255.0

! interface serial0/0

clock rate 64000

ip address 192.168.1.1 255.255.255.0

no shutdown

! interface fastEthernet0/0

no shutdown

! interface fastEthernet0/0.11

encapsulation dot1q 11

ip address 172.16.1.1 255.255.255.0

! interface fastEthernet0/0.12

encapsulation dot1q 12

ip address 172.16.2.1 255.255.255.0

! interface fastEthernet0/0.13

encapsulation dot1q 13

ip address 172.16.3.1 255.255.255.0

! router ospf 1

network 0.0.0.0 255.255.255.255 are 0

! end      

!Nhóm 2:

SW21:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN2

vtp pass CISCO

! vlan 21

name VLAN21

! vlan 22

name VLAN22

! vlan 23

name VLAN23

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 21

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 22

! interface range fastEthernet0/17 – 23

switchport mode access

switchport access vlan 23

! end  

SW22:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN2

vtp mode client

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 21

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 22

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 23

! end  

SW23:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN2

vtp mode client

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 21

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 22

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 23

! end  

R21:

! configure terminal

! interface loopback0

ip address 2.2.2.2 255.255.255.0

! interface serial0/0

clock rate 64000

ip address 192.168.1.2 255.255.255.0

no shutdown

! interface serial0/1

clock rate 64000

ip address 192.168.2.2 255.255.255.0

no shutdown

! interface fastEthernet0/0

no shutdown

! interface fastEthernet0/0.21

encapsulation dot1q 21

ip address 172.17.1.1 255.255.255.0

! interface fastEthernet0/0.22

encapsulation dot1q 22

ip address 172.17.2.1 255.255.255.0

! interface fastEthernet0/0.23

encapsulation dot1q 23

ip address 172.17.3.1 255.255.255.0

! router ospf 1

network 0.0.0.0 255.255.255.255 are 0

! end      

!Nhóm 3:

SW31:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

! interface fastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp domain BCMSN3

vtp pass CISCO

! vlan 31

name VLAN31

! vlan 32

name VLAN32

! vlan 33

name VLAN33

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 31

! interface range fastEthernet0/10 – 16

switchport mode access

switchport access vlan 32

! interface range fastEthernet0/17 – 23

switchport mode access

switchport access vlan 33

! end  

SW32:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN3

vtp pass CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 31

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 32

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 33

! end    

SW33:

! configure terminal

! interface fastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

! vtp mode client

vtp domain BCMSN3

vtp pass

CISCO

! interface range fastEthernet0/1 – 7

switchport mode access

switchport access vlan 31

! interface range fastEthernet0/9 – 16

switchport mode access

switchport access vlan 32

! interface range fastEthernet0/17 – 24

switchport mode access

switchport access vlan 33

! end

R31:

configure terminal

! interface loop 0

ip address 3.3.3.3 255.255.255.0

! interface s0/0

clock rate 64000

ip address 192.168.2.3 255.255.255.0

no shutdown

! interface fastEthernet0/0

no shutdown

! interface fastEthernet0/0.31

encapsulation dot1q 31

ip address 172.18.1.1 255.255.255.0

! interface fastEthernet0/0.32

encapsulation dot1q 32

ip address 172.18.2.1 255.255.255.0

! interface fastEthernet0/0.33

encapsulation dot1q 33

ip address 172.18.3.1 255.255.255.0

! router ospf 1

network 0.0.0.0 255.255.255.255 are 0 !

end      

!kiem tra trunk

#show int trunk  

!kiem tra vtp

#show vtp status

 !kiem tra routing table

#show ip route

Thiết Lập Cấu Hình Dòng Switch 2960, 2960X, 2960S Chuẩn Layer 2, Hướng Dẫn 7 Bước Thiết Lập Cấu Hình Switch Cisco 2960 Nói Chung / 2023

Hướng dẫn cấu hình căn bản dành cho switch cisco 2960, khách hàng có thể tham khảo và thao tác cấu hình thử. Bài viết dành cho các quản trị mạng server đã có kiến thức cơ bản về hạ tầng hệ thống mạng doanh nghiệp

Bài hướng dẫn cấu hình này sẽ mô tả cách cấu hình các thông số cơ bản cho thiết bị Switch Cisco Catalyst 2960 bao gồm: cài đặt tên, cài đặt IP và password

Các bước tiến hành thực hiện:

Bước 1: Kết nối cổng COM của laptop hoặc pc với cổng Console của Switch 2960 (cổng này được bố trí ở mặt sau của thiết bị) sử dụng cáp Rolled – Over. Các thông số để quy cập: 8 data bit, no parity, 1 stop bit, no flow control

Bước 2: Kết nối nguồn và bật switch sau đó theo dõi quá trình khởi động (khoảng 1 phút)

C2900XL Boot Loader (C2900-HBOOT-M) Version 12.0(5)XU, RELEASE

SOFTWARE (fc1) Compiled Mon 03-Apr-00 17:20 by starting... Base ethernet MAC Address: 00:02:b9:9a:85:80 Xmodem file system is available. flashfs[0]: 108 files, 3 directories flashfs[0]: 0 orphaned files, 0 orphaned directories flashfs[0]: Total bytes: 3612672 flashfs[0]: Bytes used: 2775040 flashfs[0]: Bytes available: 837632 flashfs[0]: flashfs fsck took 6 seconds. chúng tôi Initializing Flash. Boot Sector Filesystem (bs installed, fsid: 3 Parameter Block Filesystem (pb installed, fsid: 4 Loading flash:c2900XL-c3h2s-mz-120.5-

Bước 3: Khi thiết bị đã khởi động xong bạn sẽ nhận được thông báo bằng System Configuration Dialog (vì cấu hình switch hoàn toàn mới)

Giống với router, bạn cần ấn No để quá trình không chạy vào phần Setup Mode mà chuyển trực tiếp sang User Exec Mode:

Bước 4: Nhấn enable để truy cập vào privileged mode

Switch#show running-config

Building configuration...

Current configuration: ! version 12.0 no service pad service timestamps debug uptime service timestamps log uptime no service mật khẩu-encryption ! hostname Switch ! ip subnet-zero ! interface FastEthernet0/1 ! interface FastEthernet0/2 ! interface FastEthernet0/3 !

–More—

! interface VLAN1 no ip directed-broadcast no ip route-cache ! line con 0 transport input none stopbits 1 line vty 5 15 ! end

Như các thông số hiển thị bên trên, cấu hình của switch sẽ rất giống trên router, các interface trên switch là các port của switch.

Bước 5: Tếp theo, ta tiến hành đặt tên cho switch và đặt các mật khẩu truy cập

Đặt tên cho thiết bị

Switch#config terminal

Switch(config)#host ALSwitch

ALSwitch(config)#

Đặt mật khẩu

ALSwitch(config)#enable password class

ALSwitch(config)#line con 0

ALSwitch(config-line)#password cisco

ALSwitch(config-line)#login

ALSwitch(config-line)#line vty 0 15

ALSwitch(config-line)#password cisco

ALSwitch(config-line)#login

Dùng câu lệnh copy để lưu cấu hình từ RAM vào NVRAM:

ALSwitch#copy running-config startup-config

Bước 6: Tiến hành đặt địa chỉ IP cho switch để nó có thể liên lạc với các thiết bị khác qua trên mạng. Switch là một thiết bị lớp 2. Việc đặt IP address cho switch chỉ nhằm mục đích quản trị.

Tất cả các port mặt định của VLAN 1, do đó phải cấu hình cho quản lý switch dùng VLAN 1. Bạn cấu hình VLAN 1 như cấu hình một cổng giao tiếp của router khi gán địa chỉ IP.

ALSwitch#config terminal

ALSwitch(config)#interface vlan 1

ALSwitch(config-if)#ip address 10.1.1.251 255.255.255.0

Vì switch không thể cấu hình giao thức định tuyến, nên để tới tất cả các mạng, ta phải cấu hình một địa chỉ gateway mặc định để gởi tất cả lưu lượng khi ta cần liên lạc giữa các VLAN.

ALSwitch(config)#ip default-gateway 10.1.1.1

Bước 7: Cấu hình PC của bạn cho nó là một thành phần trong mạng 10.1.1.0/24 (giả sử đặt địa chỉ IP cho PC là 10.1.1.10/24). Cắm PC vào một port bất kỳ của switch.

Từ PC Telnet vào switch dùng địa chỉ đã cấu hình 10.1.1.251 (Từ Window: Start/Run/Telnet 10.1.1.251)

Sau khi đã telnet thành công, thử một số lệnh trên switch:

ALSwitch#show interfaces

FastEthernet0/1 is down, line protocol is down

Hardware is Fast Ethernet, address is 0002.fd49.7b81 (bia

0002.fd49.7b81)

MTU 1500 bytes, BW 0 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Auto-duplex , Auto Speed , 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

–More—

Lệnh show version để xem thông tin phần cứng và phần mềm

ALSwitch#show version

Cisco Internetwork Operating System Software IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5)XU, RELEASE SOFTWARE Compiled Mon 03-Apr-00 16:37 by swati Image text-base: 0x00003000, data-base: 0x00301398 ROM: Bootstrap program is C2900XL boot loader ALSwitch uptime is 16 minutes System returned to ROM by power-on System image file is flash:c2900XL-c3h2s-mz-120.5-XU.bin cisco WS-C2924-XL (PowerPC403GA) processor (revision 0x11) with 8192K/1024K bytes of memory. . . . . 24 FastEthernet/IEEE 802.3 interface(s) 32K bytes of flash-simulated non-volatile configuration memory. Base ethernet MAC Address: 00:02:FD:49:7B:80 Motherboard assembly number: 73-3382-08 Power supply part number: 34-0834-01 Motherboard serial number: FAB04301ANJ Power supply serial number: PHI04150042 Model revision number: A0 Motherboard revision number: B0 Model number: WS-C2924-XL-EN System serial number: FAB0432S2GJ Configuration register is 0xF ALSwitch#

Hướng Dẫn Cấu Hình Router Cisco, Hướng Dẫn Cấu Hình Router Cisco / 2023

Có thể được thực hiện trên mạng từ một máy chủ TFTP, có thể thực hiện thông qua giao diện menu được cung cấp khi khởi động hay có thể được thực hiện từ giao diện menu được cung cấp bởi sử dụng lệnh setup. Tuy nhiên hướng dẫn trong bài sẽ không giới thiệu các phương pháp này. Nó chỉ giới thiệu việc cấu hình từ giao diện dòng lệnh IOS. Tuy nhiên hướng dẫn sẽ rất hữu dụng đối với bất cứ ai còn lạ lẫm với các router của IOS và những người nghiên cứu CCNA.

1. Giới thiệu

Có một vài phương pháp có thể cấu hình các router của Cisco. Có thể được thực hiện trên mạng từ một máy chủ TFTP, có thể thực hiện thông qua giao diện menu được cung cấp khi khởi động hay có thể được thực hiện từ giao diện menu được cung cấp bởi sử dụng lệnh setup. Tuy nhiên hướng dẫn trong bài sẽ không giới thiệu các phương pháp này. Nó chỉ giới thiệu việc cấu hình từ giao diện dòng lệnh IOS. Tuy nhiên hướng dẫn sẽ rất hữu dụng đối với bất cứ ai còn lạ lẫm với các router của IOS và những người nghiên cứu CCNA.

Lưu ý rằng trong hướng dẫn này sẽ không giới thiệu đến việc kết nối vật lý từ router đến mạng mà nó sẽ làm nhiệm vụ định tuyến mà chỉ giới thiệu cấu hình hệ điều hành.

Lý do cho việc sử dụng dòng lệnh

Giai phap mang- Lý do chính cho việc sử dụng giao diện dòng lệnh thay vì một giao diện điều khiển thông qua menu cho phép thực hiện nhanh hơn là khi bạn đầu tư thời gian vào việc nghiên cứu các lệnh, bạn có thể thực hiện nhiều hoạt động nhanh hơn nhiều so với việc sử dụng menu. Điều này tạo ra lợi thế của việc sử dụng dòng lệnh so với các giao diện menu. Còn có những điều làm cho nó trở lên đặc biệt hiệu quả khi nghiên cứu giao diện dòng lệnh của Cisco IOS rằng nó là một chuẩn cho tất cả các router của Cisco. Thêm vào đó nữa là một số câu hỏi trong bài kiểm tra về CCNA yêu cầu bạn biết về các lệnh này.

2. Bắt đầu với Cisco

Bắt đầu bạn có thể cấu hình router của mình từ một thiết bị đầu cuối. Nếu router đã được cấu hình và có tối thiểu một cổng được cấu hình với một địa chỉ IP nào đó thì nó sẽ có một kết nối vật lý với mạng, từ đó bạn có thể telnet đến router và cấu hình nó trên mạng. Nếu nó chưa được cấu hình thì bạn cần phải kết nối trực tiếp router với một thiết bị đầu cuối và cáp nối tiếp. Với các máy tính Windows, bạn có thể sử dụng Hyperterminal để kết nối một cách dễ dàng đến router. Cắm cáp nối tiếp vào cổng COM trên máy tính và đầu còn lại cắm vào cổng trên router. Khởi chạy Hyperterminal, chuyển tới cổng COM mà bạn sử dụng và kích OK. Thiết lập tốc độ kết nối là 9600 baud và kích OK. Nếu router chưa được bật nguồn, hãy bật nguồn cấp cho nó.

Nếu bạn muốn cấu hình router từ máy tínhLinux, cần phải có Seyon hoặc Minicom, thì tối thiểu một trong số chúng, có thể là cả hai sẽ đi kèm bản phân phối Linux của bạn.

Nếu nó đã được cấu hình từ trước với một hostname, khi đó bạn sẽ thấy:

Nếu bạn vừa mới bật router, sau khi khởi động nó sẽ yêu cầu bạn xem có muốn bắt đầu cấu hình từ đầu hay không. Hãy từ chối trả lời. Nếu bạn đồng ý thì nó sẽ đưa bạn đến giao diện menu. Chính vì vậy hãy chọn nó.

Các chế độ

Giao diện dòng lệnh của Cisco IOS được tổ chức theo ý tưởng các chế độ (mode). Bạn chuyển vào và ra một vài chế độ khác nhau trong khi cấu hình router, chế độ nào bạn nằm trong đó sẽ quyết định những lệnh nào bạn có thể sử dụng. Mỗi một chế độ có một tập các lệnh hiện hữu cho nó, một số các lệnh chỉ có sẵn trong chế độ nào đó. Trong bất cứ chế độ nào, việc đnahs một dấu hỏi chấm sẽ hiển thị một danh sách các lệnh hiện hữu trong chế độ đó.

Các chế độ đặc quyền và không đặc quyền

Khi bạn lần đầu tiên kết nối đến router và cung cấp mật khẩu (nếu cần thiết), bạn sẽ vào chế độ EXEC, chế độ đầu tiên mà bạn có thể sử dụng các lệnh từ dòng lệnh. Từ đây, bạn có thể sử dụng các lệnh không đặc quyền như ping, telnet, and rlogin. Có thể sử dụng lệnh show để thu về các thông tin hệ thống. Trong chế độ đặc quyền, bạn có thể sử dụng lệnh show version để hiển thị phiên bản của IOS mà router đang chạy. Đánh show ? sẽ hiển thị tất cả các lệnh show hiện hữu trong chế độ mà bạn đang hiện diện.

Bạn phải vào chế độ đặc quyền để cấu hình cho router của mình. Thực hiện điều đó bằng cách sử dụng lệnh enable. Chế độ đặc quyền thường được bảo vệ mật khẩu trừ khi router chưa được cấu hình. Bạn có thể chọn chế độ đặc quyền không bảo vệ mật khẩu tuy nhiên tất cả đều nên đặt mật khẩu để an toàn. Khi phát lệnh enable và cung cấp mật khẩu, bạn sẽ vào chế độ đặc quyền.

Để giúp người dùng theo dõi được chế độ nào họ đang ở trong, nhắc lệnh của dòng lệnh sẽ thay đổi mỗi khi bạn vào một chế độ khác. Khi bạn chuyển từ chế độ không đặc quyền sang chế độ đặc quyền, nhắc nhở sẽ thay đổi từ:

Thành

Router#

Điều này sẽ không cần thiết nếu chỉ có hai chế độ. Tuy nhiên trong thực tế, với nhiều chế độ nên tính năng này rất cần thiết. Bạn cũng cần chú ý đến nhắc nhở mọi lúc.

Router(arguments)#

Chúng vẫn kết thúc bằng dấu (#) và được gộp vào trong chế độ đặc quyền. Nhiều chế độ có các chế độ con trong bản thân nó. Khi ban vào chế độ đặc quyền, bạn có thể truy cập vào tất cả các thông tin cấu hình cũng như các tùy chọn mà IOS cung cấp, trực tiếp từ chế độ cha hay từ một trong các chế độ con của nó.

3. Cấu hình router Cisco

Nếu bạn vừa với bật router, nó sẽ hoàn toàn chưa được cấu hình. Nếu nó đã được cấu hình, bạn có thể xem được cấu hình hiện hành của nó. Thậm chí nếu nó chưa được cấu hình từ trước thì bạn cũng có thể tự khai thác bằng lệnh show trước khi bắt đầu cấu hình router. Vào chế độ đặc quyền bằng cách phát lệnh enable, sau đó phát một vài lệnh show để xem những gì chúng hiển thị. Nhớ rằng, lệnh show ? sẽ hiển thị tất cả các lệnh show hiện hữu trong chế độ hiện hành. Hãy thử với các lệnh duới đây:

Router#show interfaces Router#show ip protocols Router#show ip route Router#show ip arp

Khi vào chế độ đặc quyền bằng cách sử dụng lệnh enable, khi đó bạn sẽ nằm trong chế độ top-level của chế độ đặc quyền, được biết trong tài liệu này là “chế độ cha – parent”. Nó là chế độ mà bạn có thể hiển thị hầu hết các thông tin về router. Như những gì bạn biết, bạn có thể thực hiện điều đó với các lệnh show. Ở đây bạn có thể biết được về cấu hình của giao diện. Có thể hiển thị các giao thức IP đang được sử dụng là gì, chẳng hạn như các giao thức định tuyến động. Bạn có thể xem tuyến và bản định tuyến ARP và một số các tùy chọn quan trọng khác.

Khi cấu hình router, bạn sẽ vào trong một số chế độ con để thiết lập các tùy chọn, sau đó trở về chế độ cha để hiển thị các kết quả. Bạn cũng trở về chế độ cha để vào các chế độ con khác. Để trở vè chế độ cha, bạn chỉ cần nhấn ctrl-z. Thao tác này sẽ làm các lệnh mà bạn vừa phát ra có hiệu lực và đưa bạn trở về chế độ cha.

Cấu hình toàn cục

Để cấu hình bất cứ tính năng nào của router, bạn phải vào chế độ cấu hình. Đây là chế độ con đầu tiên của chế độ cha. Trong chế độ cha, bạn phát lệnh config.

Router#config Router(config)#

Như minh chứng ở trên, nhắc nhở sẽ thay đổi để chỉ thị răng bạn đang ở trong chế độ nào lúc này.

Trong chế độ cấu hình, bạn có thể thiết lập các tùy chọn để sử dụng cho toàn hệ thống, được ám chỉ như là các cấu hình mang tính toàn cục. Cho ví dụ, đặt tên cho router để bạn có thể dễ dàng nhận ra nó. Bạn có thể thực hiện điều đó trong chế độ cấu hình với lệnh hostname.

Router(config)#hostname ExampleName ExampleName(config)#

Như minh chứng ở trên, khi bạn thiết lập tên của host với lệnh hostname, nhắc nhở sẽ ngay lập tức thay đổi bằng cách thay thế Router thành ExampleName. (Lưu ý: nên đặt tên cho các router của bạn theo một lược đồ tên có tổ chức).

Một lệnh hữu dụng khác được phát từ chế độ cấu hình là lệnh để chỉ định máy chủ DNS nhằm sử dụng cho router:

ExampleName(config)#ip name-server aa.bb.cc.dd ExampleName(config)#ctrl-Z ExampleName#

Đây cũng là nơi bạn thiết lập mật khẩu cho chế độ đặc quyền.

ExampleName(config)#enable secret examplepassword ExampleName(config)#ctrl-Z ExampleName#

Cho tới khi bạn nhấn ctrl-Z (hoặc đánh exit cho tới khi bạn vào được chế độ cha) lệnh của bạn mới không bị ảnh hưởng. Bạn có thể vào chế độ cấu hình, phát một vài lệnh khác nhau, sau đó nhấn ctrl-Z để kích hoạt chúng. Mỗi lần bạn nhấn ctrl-Z, bạn sẽ trở về chế độ cha và nhắc:

ExampleName#

Ở đây bạn sử dụng lệnh show để thẩm định các kết quả của các lệnh mà mình đã phát trong chế độ cấu hình. Để thẩm định các kết quả của lệnh ip name-server, phát lệnh show host.

Cấu hình giao diện

Việc đặt tên giao diện Cisco rất đơn giản. Các giao diện riêng biệt được dẫn đến bởi thủ tục này:

media type slot#/port#

“Media type” là kiểu thiết bị có giao diện là cổng, chẳng hạn như Ethernet, Token Ring, FDDI, nối tiếp,… Số khe chỉ thích hợp với các router cung cấp số khe để bạn có thể cài đặt các modul. Các modul gồm có một vài cổng cho thiết bị đã cho. Serie 7200 là một ví dụ. Các modul này có thể thay nóng. Bạn có thể remove một modul nào đó ra khỏi khe của nó và thay thế nó bằng một modul khác mà không cần phải ngắt dịch vụ được cấp bởi các modul khác đã cài đặt trong router. Các khe này được đánh số trên router.

Số cổng dựa vào cổng tham chiếu với các cổng khác trong modul đó. Việc đánh số được tiến hành từ trái sang phải và tất cả đều bắt đầu từ số 0, không phải một chữ số.

Cho ví dụ, Cisco 7206 là router serie 7200 có 6 khe. Để ám chỉ cho một giao diện là cổng thứ ba của một modul Ethernet đã được cài đặt trong khe thứ sáu, nó sẽ là giao diện 6/2. Chính vì vậy, để hiển thị cấu hình của giao diện, bạn cần sử dụng lệnh:

ExampleName#show interface ethernet 6/2

Nếu router của bạn không có các khe, giống như 1600, thì tên giao diện chỉ gồm có:

media type port#

Cho ví dụ:

ExampleName#show interface serial 0

Đây là một ví dụ về việc cấu hình một cổng nối tiếp với một địa chỉ IP:

ExampleName#config ExampleName(config)#interface serial 1/1 ExampleName(config-if)#ip address 192.168.155.2 255.255.255.0 ExampleName(config-if)#no shutdown ExampleName(config-if)#ctrl-Z ExampleName#

Sau đó thẩm định cấu hình:

ExampleName#show interface serial 1/1

Lưu ý về lệnh no shutdown. Một giao diện có thể được cấu hình đúng và kết nối vật lý nhưng vẫn gặp phải vấn đề. Trong trạng thái này nó sẽ không hoạt động. Lệnh gây ra lỗi này là shutdown.

ExampleName(config)#interface serial 1/1 ExampleName(config-if)#shutdown ExampleName(config-if)#ctrl-Z ExampleName#show interface serial 1/1

Trong Cisco IOS, cách đảo hoặc xóa các kết quả cho bất cứ lệnh nào là đặt no vào đằng trước nó. Cho ví dụ, nếu bạn muốn hủy gán địa chỉ IP mà đã gán cho giao diện nối tiếp 1/1:

ExampleName(config)#interface serail 1/1 ExampleName(config-if)#no ip address 192.168.155.2 255.255.255.0 ExampleName(config-if)ctrl-Z ExampleName#show interface serial 1/1

Cấu hình và định tuyến

Giai Phap Mang- Việc định tuyến IP được kích hoạt một cách hoàn toàn tự động trên các router Cisco. Nếu nó đã bị vô hiệu hóa từ trước trên router của bạn thì bạn có thể kích hoạt nó trở lại trong chế độ cấu hình bằng lệnh ip routing.

ExampleName(config)#ip routing ExampleName(config)#ctrl-Z

Có hai cách chính một router biết được nơi nó gửi các gói. Quản trị viên có thể gán các tuyến tĩnhstatic routeshoặc router có thể biết về các tuyến bằng cách sử dụng giao thức định tuyến độngdynamic routing protocol.

Ngày nay, phương pháp định tuyến tĩnh nhìn chung thường được sử dụng trong các mạng rất đơn giản hoặc trong những trường hợp mà ở đó bắt buộc cần phải sử dụng đến chúng. Để tạo một tuyến tĩnh, quản trị viên chỉ cần lệnh cho hệ điều hành để bất cứ lưu lượng mạng nào được dự trù cho địa chỉ lớp mạng cụ thể nào đó cần phải được chuyển tiếp đến một địa chỉ lớp mạng cụ thể như vậy. Trong Cisco IOS, điều này được thực hiện với lệnh ip route.

ExampleName#config ExampleName(config)#ip route 172.16.0.0 255.255.255.0 192.168.150.1 ExampleName(config)#ctrl-Z ExampleName#show ip route

Có hai thứ cần phải nói trong ví dụ này. Đầu tiên đó là địa chỉ đích phải chứa subnet mask cho mạng đích đó. Thứ hai, địa chỉ nó gửi chuyển tiếp đến là địa chỉ được chỉ định của router tiếp theo cùng với đường dẫn đến đích. Đây là cách chung nhất cho việc thiết lập một tuyến tĩnh. Mặc dù vậy vẫn còn có một số phương pháp khác.

Các giao thức định tuyến động, chạy trên các router được kết nối, cho phép các router này chia sẻ các thông tin định tuyến. Điều đó cho phép các router biết được các tuyến nào có sẵn đối với chúng. Ưu điểm của phương pháp này là các router có thể điều chỉnh để thay đổi topo mạng. Nếu một tuyến vật lý nào đó bị gỡ bỏ hoặc router bên cạnh sẽ liền kề đó gặp trục trặc thì giao thức định tuyến sẽ tìm kiếm tuyến mới. Giao thức định tuyến có thể chọn động giữa các tuyến có thể dựa trên các biến như sự tắc nghẽn mạng hay khả năng tin cậy của mạng.

Có nhiều giao thức định tuyến khác nhau, tất cả chúng đều sử dụng các biến khác nhau để quyết định trên các tuyến thích hợp. Tuy nhiên, một router cần phải chạy cùng các giao thức định tuyến như các router liền kề của nó. Mặc dù vậy nhiều router có thể chạy nhiều giao thức. Thêm vào đó cũng có nhiều giao thức được thiết kế để có thể chuyển qua các thông tin định tuyến đến được các giao thức định tuyến khác. Điều này được gọi là sự phân phối lại. Ở đây chúng tôi chỉ giới thiệu một lệnh IOS redistribute để bạn có thể nghiên cứu nếu cần thiết.

Tài liệu này miêu tả các cấu hình Routing Information Protocol (RIP) trên các router Cisco. Từ dòng lệnh, chúng ta phải lệnh cho router về giao thức nào để nó sử dụng và những mạng gì giao thức sẽ định tuyến cho.

ExampleName#config ExampleName(config)#router rip ExampleName(config-router)#network aa.bb.cc.dd ExampleName(config-router)#network ee.ff.gg.hh ExampleName(config-router)#ctrl-Z ExampleName#show ip protocols

Lưu cấu hình router

Nếu tắt router và bật nó trở lại, bạn sẽ phải bắt đầu việc cấu hình lại lần nữa. Cấu hình đang chạy của bạn không được lưu vào bất cứ kho lưu trữ vĩnh cửu nào. Bạn có thể thấy được cấu hình này bằng lệnh show running-config.

ExampleName#show running-config

Nếu muốn lưu cấu hình đang chạy thành công, bạn hãy phát lệnh copy running-config startup-config.

ExampleName#copy running-config startup-config

Cấu hình của bạn lúc này sẽ được lưu vàonon-volatile RAM(NVRAM). Phát lệnh show startup-config.

ExampleName#show startup-config

Lúc này bất cứ khi nào bạn cần đưa router của mình về cấu hình đó, hãy phát lệnh copy startup-config running-config.

ExampleName#copy startup-config running-config

Cấu hình ví dụ

Router#config

Router(config)#hostname N115-7206

N115-7206(config)#interface serial 1/1

N115-7206(config-if)ip address 192.168.155.2 255.255.255.0

N115-7206(config-if)no shutdown

N115-7206(config-if)ctrl-z

N115-7206#show interface serial 1/1

N115-7206#config

N115-7206(config)#interface ethernet 2/3

N115-7206(config-if)#ip address 192.168.150.90 255.255.255.0

N115-7206(config-if)#no shutdown

N115-7206(config-if)#ctrl-z

N115-7206#show interface ethernet 2/3

N115-7206#config

N115-7206(config)#router rip

N115-7206(config-router)#network 192.168.155.0

N115-7206(config-router)#network 192.168.150.0

N115-7206(config-router)#ctrl-z

N115-7206#show ip protocols

N115-7206#ping 192.168.150.1

N115-7206#config

N115-7206(config)#ip name-server 172.16.0.10

N115-7206(config)#ctrl-z

N115-7206#ping archie.au

N115-7206#config

N115-7206(config)#enable secret password

N115-7206(config)#ctrl-z

N115-7206#copy running-config startup-config

N115-7206#exit

4. Khắc phục sự cố router Cisco

Giai phap mang- Chắc hẳn trong quá trình sử dụng sẽ nảy ra các vấn đề. Thường nó là lỗi mà người dùng thấy rằng họ không thể đến được một đích nào đó, hoặc tất cả các đích. Bạn cần phải biết cách để kiểm tra cách router đang cố gắng định tuyến lưu lượng và phải có khả năng kiểm tra và phát hiện điểm lỗi.

Cho đến đây bạn đã thâm thiện với các lệnh show, cả hai lệnh cụ thể và cách học những gì lệnh show hiện có. Một số các lệnh cơ bản và hữu dụng nhất mà bạn có thể sử dụng cho việc khắc phục sự cố đó là:

ExampleName#show interfaces ExampleName#show ip protocols ExampleName#show ip route ExampleName#show ip arp

Kiểm tra kết nối

Một công cụ chuẩn đoán đơn giản và hữu dụng đó chính là lệnh ping. Ping là một thực thi của IP Message Control Protocol (ICMP). Lệnh này sẽ gửi đi một yêu cầu ICMP echo đến địa chỉ IP đích. Nếu đích nhận được yêu cầu thì nó đáp trả lại bằng một gói phúc đáp ICMP echo. Tín hiệu đó thay thế cho các câu đối thoại như:

Xin chào, bạn có ở đó không? Vâng, tôi đây.

ExampleName#ping xxxxxxxx

Nếu sau khi ping thành công, bạn sẽ biết được rằng đích đến mà bạn đang muốn truy cập hiện đang tồn tại và có thể kết nối đến.

Nếu có nhiều router giữa router của bạn và đích đến thì bạn sẽ khó khăn trong việc kết nối đến chúng, khi đó vấn đề có thể nằm ở các router khác. Thậm chí nếu bạn ping một router và nó đáp trả lại thì có thể một số các giao diện khác gặp vấn đề, bảng định tuyến của nó có thể bị lỗi hoặc một số vấn đề khác có thể phát sinh.

Để xem nơi các gói tin bị bỏ lại trên router của bạn khi trên đường đi đến một đích nào đó, khoảng cách bao xa, bạn hãy sử dụng lệnh trace.

ExampleName#trace xxxxxxxx

Có thể mất đến vài phút cho tiện ích này làm việc, chính vì vậy bạn cần phải kiên nhẫn chờ đợi. Nó sẽ hiển thị một danh sách tất cả các bước nhảy thực hiện trên đường đến đích.

Lệnh debug

Có một số lệnh debug được cung cấp bởi IOS. Các lệnh này không được giới thiệu ở đây, các bạn có thể tham khảo nó trong các website của Cisco.

Các kết nối phần cứng và vật lý

Kiểm tra xem router của bạn có được bật hay không. Cũng cần phải bảo đảm rằng không có cáp nào bị hỏng hoặc lỏng. Cũng cần bảo đảm rằng các cáp được cắm đúng cổng. Ngoài lời khuyên đơn giản này, bạn cần phải kiểm tra thêm các nguồn trợ giúp khác.

Ngoài tầm kiểm soát

Nếu điểm lỗi không nằm trên đường dây thì vấn đề có thể nằm trên thiết bị. Khi đó bạn có thể gọi đến quản trị viên thiết bị, thông báo cho họ biết về vấn đề bạn gặp phải và hỏi trợ giúp từ họ.

Hướng Dẫn Cấu Hình Cameraddns / 2023

Như Phương Việt đã thông báo, HIKVISION vừa ra mắt bản cập nhật firmware, cho phép người dùng có thêm lựa chọn xem qua mạng bằng phương thức tên miền động – với tên gọi CameraDDNS. Để cài đặt tên miền CameraDDNS, chúng ta có thể thực hiện theo 5 bước sau: 1. Đăng nhập cổng thông tin: http://cameraddns.net/ Lưu ý, ở thời điểm hiện tại, cổng thông tin chưa hỗ trợ mã hóa giao thức https, do vậy chúng ta có thể làm theo hình dưới để truy cập: 2. Khởi tạo tài khoản: 3. Trong trang cấu hình CameraDDNS, điền vào các thông tin về tên miền muốn khởi tạo cho thiết bị. Sau khi điền các thông tin, nhấn nút “Thêm mới” để xác nhận. 4. Sau khi khởi tạo tên miền thành công, chúng ta cần gán tên miền này cho thiết bị đang cài đặt. Kích chọn hộp kiểm Enable DDNS, chọn loại tên miền Camera DDNS. Điền vào các thông tin về tên miền đã khởi tạo: Lưu ý: + Thiết bị phải được cập nhật firmware hỗ trợ CameraDDNS + Việc cấu hình trên có thể thực hiện thông qua màn hình trực tiếp hoặc trình duyệt web Sau khi điền đẩy đủ và chính xác các thông tin, nhấn nút Apply để xác nhận. Mục trạng thái (Status) báo “DDNS status is normal” đồng nghĩa việc cài đặt trên thiết bị đã thành công. 5. Cuối cùng, để truy cập thiết bị qua trình duyệt web, chúng ta có thể gõ vào địa chỉ như sau : http://cameraddns.net/phuongviettest hoặc http://phuongviettest.cameraddns.net Trong quá trình thao tác cấu hình CameraDDNS, mọi yêu cầu hỗ trợ Quý đối tác vui lòng liên hệ hotline kỹ thuật Phương Việt:

Kỹ thuật hỗ trợ 1: 096 815 2772

Kỹ thuật hỗ trợ 2: 096 446 2233

Bạn đang xem bài viết Cấu Hình Switch Port, Vlans, Trunk, Vtp, Intervlan Routing / 2023 trên website Uplusgold.com. Hy vọng những thông tin mà chúng tôi đã chia sẻ là hữu ích với bạn. Nếu nội dung hay, ý nghĩa bạn hãy chia sẻ với bạn bè của mình và luôn theo dõi, ủng hộ chúng tôi để cập nhật những thông tin mới nhất. Chúc bạn một ngày tốt lành!